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Introduction 

 

Welcome to 3DF Zephyr 
 

3DF Zephyr allows you to automatically reconstruct 3D models from photos. The process 
is completely automatic and no coded targets, manual editing or special equipments are 
needed. 3DF Zephyr is built on top of our proprietary, cutting-edge, reconstruction 
technology. 3DF Zephyr  comes with a user friendly interface, and the possibility to export 
in many common 3D formats or even to generate lossless video without the need of 
external tools. Furthermore it is possible to generate true orthophotos, digital elevation 
models (DTM) and even calculating areas, volumes, angles and contour lines. 3DF 
Zephyr is the perfect tool for modeling from reality. 
 

Here in 3Dflow we worked really hard to build up both the core technologies and the user 
interface. The obtained solution is in all probability the most accurate, completely 
automatic, best engineered multiview-stereo algorithm available on the market.  
  
If you need further help, if you would like to request features or if you simply want to 
discuss about the product and the technology behind, please remember that our forum 
(http://forum.3dflow.net) is always willing to receive new users. 
 

Before starting, you might want to read some hints and tips on how to take the 'correct' 
photos and the overview of the reconstruction process. 
 

If you prefer you also can jump start and directly Start a new Project. 
 

Moroever, please note that there are also free online tutorials available, featuring also 
demo datasets you can download and more in-depth tips and tricks: our tutorials are 
available at the url http://www.3dflow.net/it/technology/documents/3df-zephyr-tutorials/ 

System Requirements 

3DF Zephyr is a computationally demanding application. It takes advantage of all 
available Cpu cores and it makes use of the nvidia CUDA technology where available. 
Please note that a CUDA enabled Video Card can drastically improve the performances 
(multi gpu configurations are supported as well in Evaluation, Pro and Education). We 
also suggest to exit all running applications when performing a reconstruction with 3DF 
Zephyr. 
 

Minimum System Requirements: 
 

OS: Windows 10/8.1/8/7/Vista (64 bit) 
Processor: Dual Core 2.0GHz or equivalent processor 
Memory: 4GB System RAM 

Hard Disk Space: 4GB free HDD Space 

Video Card: Direct X 9.0c compliant video card with 256 MB of RAM 

 

Recommended  System Requirements: 
 

OS: Windows 10/8.1/8/7/Vista 64 bit 
Processor: Quad-core Intel or AMD CPU 

Memory: 8GB System RAM 

http://forum.3dflow.net/
http://www.3dflow.net/it/technology/documents/3df-zephyr-tutorials/
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Hard Disk: 10GB free HDD Space - SSD drive 

Video Card: DirectX 9.0c  NVIDIA video card with 1GB of RAM (Nvidia GeForce GTX 260 
or higher; Nvidia CUDA 2000 or higher) 
 

Versions 

3DF Zephyr comes in three versions: Pro, Aerial and Lite. 
 

3DF Zephyr Pro is the standard  solution conceived for application fields such as 
architecture, archaeology, medicine & dentistry and body scanning. 
 

3DF Zephyr Aerial is the dedicated version to aerial photogrammetry and it involves 
topography, urban monitoring, nature hazard, mining and precision agriculture world. 
 

3DF Zephyr Lite is a commercial solution aimed to small businesses, artists or in general 
to those user who just want to obtain a 3D mesh and/or those who don't need all the tools 
available in the other versions. The most important limitations are the export capabilities 
(no point clouds can be exported), no Ortophoto/Ortomosaic generation and maximum 
one GPU will be used when doing computations. 
 

3DF Zephyr Pro, Lite and Education require an online activation. 

Activation 

3DF Zephyr Pro, Lite and Aerial editions require an online activation (3DF Zephyr Lite 
Steam Edition will work through the Steam Application by Valve and does not require a 
product key)  
 

The product keys are supplied by mail at the moment of purchase. If you lost your 
product key, please get in touch with our technical support so that we can resolve your 
issue. 
 

You can activate your software either during installation or on the first run. 
 

The activation process will bind the product key to the computer.  
 

Usually a product key can be activated only on one computer at a time.  You can always 
deactivate the software by using the uninstaller. 
 

If you have problems regarding online activation or deactivation, please write an email to 
sales@3dflow.net. A manual offline activation process can also be issued in special 
cases. 
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Documentation 

 
 

3Dflow pushed a lot of effort to make Zephyr's interface as more user friendly as 
possible. 
However, if you want to get the best results, please spend a few minutes reading the 
hints and tips you will find in this documentation. 
 

This guide is intended for all the different versions of 3D Zephyr unless stated otherwise. 
 

In the next section, we will quickly review the reconstruction process. It is not mandatory 
to fully understand the "magic" behind zephyr, but a quick review of the main concepts 
can be useful. 

A Quick Overview 

Here in 3Dflow we are, first of all, Computer Vision researchers. Computer Vision is, 
generally speaking, the science that studies how to extract (any kind of useful) 
information starting from images. This is a very rough definition and many subproblem 
can be delineated and many different meanings for the concept of "information" can be 
given. Extracting three-dimensional models from a number of images (extracting 3D 
information from a 2D input) is a well studied problem in Computer Vision. 3DF Zephyr 
represents an highly refined and well engineered solution for this problem. 
  
There are four main phases in Zephyr: 

 Starting a new project an Aligning the Cameras - this is also referred as 'Structure 
from Motion' 

 Extracting a Dense Point Cloud - this is also referred as 'Multi-View Stereo' 

 Extracting a Surface 

 Extracting a Textured Mesh 

 

When starting a new project the software will extract the camera positions and 
orientations and their internal parameters (i.e. the focal lenght and other camera 
properties). The first are referred as external parameters, while the latter are called 
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internal parameters. All the magic of this phase is done by Samantha, our leading 
Structure from Motion Technology. If you want to input the internal camera parameters 
manually instead of letting Samantha estimate them, you can. 
 

After the cameras have been aligned, you can proceed and extract a dense 
reconstruction. The process requires the input cameras to be correct. If you believe a 
camera is not correctly aligned, you can remove it from the workspace. Before 
proceeding you can also restrict or expand the volume of reconstruction. The 
reconstruction process is powered by Stasia, our Multi-View Stereo technology. You can 
create different dense reconstructions (with varying parameters) and save them into the 
workspace. 
 

Starting from a dense reconstruction, you can create a triangular mesh. Basing on what 
you are going to reconstruct you can choose among the generation of a smoothed 
surface (when dealing with human body or terrains for instance) or the generation of a 
sharp surface that more fits scene such as buildings or mechanical parts. The latter kind 
of surfaces are handled by Sasha, the latest algorithm developed by 3Dflow. 
 

Every mesh polygon get textured with pictures zone where it is detected. Within texture 
generation phase there is a color balance algorithm as well, that allows to select and set-
up the best color for each pixel automatically by checking the different lighting changes 
on the photos. 
 

In the next section we will give some hints and tips on how to take the right photos. 
 

Photography Guide 

 
 

In this section we will list some tips to obtain good reconstructions. 3DF Zephyr is 
completely automatic but does require some forethought to produce the best results. 
 

Camera sensors. 
 

What you'd better keep in mind when picking your gear: 
 

 camera performance is not provided by its megapixels resolution; 

 high-end cameras do not always lead to better result; 
 

A good camera must allow a full light management in order to control each exposition 
value. That's why DSLR cameras (reflex) are usually recommended even if both 
mirrorless and bridge camera can fit that need. 
 

http://samantha.3dflow.net/
http://stasia.3dflow.net/
http://www.3dflow.net/technology/
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Camera sensor is the real highlight of the matter and the following hints could be quite 
helpful: 
 

 Pixels size must be higher than 2 µm; therefore it is strongly recommended to exploit 
camera sensor bigger than 1/2.3" even if smaller sensors may be used depending on 
the accuracy you want to reach; 

 

 You'd better draw your attention to pixels size rather than pixels mount for each 
picture. For instance, if a 36 megapixel full-frame reflex (35.9 x 24 mm) is being 
employed it is worthwhile to shoot at a lower resolution than the maximum provided. 
That is the way to get bigger pixels in the images even though less; 

 

Lenses. 
 

Every survey has its own features and conditions so choosing the most suitable lens for 
that depends on both environment status (light, obstacles on field, user movement 
capability) and features of the survey subject/scene. Following a few tips are provided so 
as to pick the proper photographic gear: 
 

 Full-frame cameras: use lenses with focal lenght value between 25 and 50 mm; 
 

 Aps-c cameras or lower sensor size: use lenses with focal lenght value between 18 
and 35 mm considering a crop factor value between 1.5 e 1.6; 

 

It is strongly recommended to shoot keeping the same focal lenght for all the pictures you 
take. Even if Zephyr can handle several kind of cameras and lenses at the same time 
and in the same project, you can get better and faster results if working with an 
equivalent set-up; 
 

Shooting techniques. 
 

Following some proposals for standard photographic acquisition are featured. At any rate 
survey modalities are different and need to be adapted on a case by case basis. 
 

Parallel axis capture 

 

 
 

That is exploited with planar or regular surface in application fields such as architecture and aerial 
photogrammetry.  Red fills show the overlap area among the pictures taken. 

 
 



3DF Zephyr 

8 / 61 

Convergent axis capture 

 

 
 

That is exploited when it is allowed to move around the subject/scene. 
 

If a an small or medium size object is needed to be fully reconstructed it is possible to 
keep the camera in a fixed position (on a tripod for instance) and to put the object on a 
turntable. Then 3DF Masquerade will allow to hide the background in the pictures. 
 

General rules. 
 

 Keep the subject on the center of the framing; 
  

 Avoid direct light sources that may cast shadows and hide surface areas; 
 

 Avoid high ISO value since the noise may set back the Structure from Motion phase in 
Zephyr; 

 

 Keep a high aperture value (f/8 - F/16) when possible as it helps get a deep depth of 
field on pictures; 

 

 Avoid blurry photos. Using good quality cameras and having a good illumination can 
help. Consider also using a tripod if necessary. 

 

 Have a lots of overlap on each photo (70-80%). This is probably the most important 
tip. Shoot as many photos you can. Each part of the scene you're shooting should 
appear in at least three separate views taken from different locations. This is a 
minimum requirement, taking more photos will likely improve the final results. 

 

 Limit the angles between photos. When moving around objects, try to keep the angle 
between each photo very low. 

 

 Shoot scenes with lots of detail and texture. The visual texture in the photos is what 
ties them together. 3DF Zephyr does not work well with uniform or highly repetitive 
texture and does not work at all with specular or transparent objects. You can, 
however, mask out certain areas using 3DF Masquerade (bundled with 3DF Zephyr) 

 

 Don't try to adjust lens distorsion as that error is quite essential during the first phase 
of Structure from Motion; 
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 Even if 3DF Zephyr can deal with different cameras or lenses within the same 
dataset, you will obtain better results by using the same camera with the same focal 
length. 

 

 Be redundant: the more photos you take, the better results you will get.  
 
 

Remember that you can even use the Image Quality Index inside Zephyr to check the 
status of the pictures you are working on. 
 

The Main Window 

When opening Zephyr for the first time, the interface layout will look like this: 
 

 
 
 

On the upper side, the menubar and the toolbar give you access to all the basic actions 
and functionality of Zephyr. 
 

The Render window at the center let you navigate through the 3D scene. You can also 
right click on it to open a contextual menu to perform specific actions. 
The other windows are completely "dockable"; this means you can move them and dock 
in any part of the main window. To hide or show a specific dock use the View menu. 
3DF Zephyr always saves and loads the interface layout of your last run. From Tools > 
Options > Application > Restore Settings you can restore the factory default settings 
(including the interface layout). 
 

On the left side, in the Project tab you can review all the objects currently loaded in the 
workspace. The Objects are divided into 4 categories: cameras, sparse point cloud, 
dense point clouds and meshes. You can remove, rename and edit every object by right 
clicking on them and selecting the specific action. 
 

On the left side you can find even the Animation tab, where you are allowed to create 
and export video animantion of your 3D models. 
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On the right side there are the Control Points tab, the Measurements tab and the 
Drawing tab as well. 
 

On the same tab, the History tab let you review, undo and redo the performed actions. 
 

The Navigation bar is located in the bottom side alongside the thumbnails of the photos 
loaded in Zephyr and the Log pane. 
 
 

OPTIONS 

 

By clicking the wrench icon in the toolbar or selecting Tools in the menu bar you can 
enter the Option window arranged in four tabs: Rendering, Imput, Cuda and Application. 
 

 
 
 

The Rendering tab allows you to edit 3DF Zephyr graphic appearance. You can modify  
the colors of several items ranging from the work space to the grid and control points. As 
for point clouds generated within 3DF Zephyr you can change the graphic size of 
individual points. As for the cameras you can edit at any time the alpha channel which is 
worthwhile to set both the images transparency and the size and color of cones detecting 
shots in three-dimensional space. 
 

The Input tab allows to change parameters related to the visualization and virtual camera 
control. 
 

The Cuda tab allows you to enable the graphics card with CUDA technology if that is 
located in the hardware components of your computer. 
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The Application tab allows to change some features of the software such as the 
operating language, the text size and enable the autosave that could be quite important 
when running 3D reconstructions in batch processing. 

Starting a new project 

Got the Photos? Then you are ready to begin the reconstruction process! 
 
 
 

To create a new project, just click on Workflow > New Project (1) . The Project Wizard 
(3) screen will appear which will guide you through the process of importing your pictures. 
 

 
 

For standard workflow you simply click on the Next button and going on adding your 
photographs within the software. 
 

However, in that wizard there are two submenus called Imports (3) and Additional 
options (4). 
 

Inside the Imports menu you have two options: 
 

 Import control points contraints: 3DF Zephyr does not need any pre-calibration file; 
anyway, if you have a calibration file created with your own equipment, you can load 
the calibration file by selecting this option. By clicking on the Next button you will find 
a further submenu where you can choose whether: 

 

 - manually enter each internal and external parameter (for each image); 

 - specify the position and the Euler angles; 

 - import internal and external parameters using a text file; 

 

 Import camera position constraints: as the previous option, this one allows you to 

import camera position(by loading a txt file) in 3DF Zephyr and to use them to 
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constrain the 3D reconstruction; a standard example of practical usage of this entry is 

represented by the pictures taken by drone or UAV system record recording GPS 

coordinates of the shots into the Exif data. 

 

In the Additional options submenu (4) you can specify the software to perform each of 
the four 3D reconstruction phases without stopping between a phase and the other one; 
this tool can be very helpful when you don't have enough time to set your 3D 
reconstruction in details . This technique is called batch processing and is only 
recommended for advanced users, as it represents the highest level of automation in 
3DF Zephyr. 
 

 
 

In Additional options (4) the Check online for precomputed camera calibration 
option allows to save camera calibration parameters on a 3DF Zephyr online database so 
that the software will be able to automatically get that providing the exact calibration 
parameters and reducing the timing of Structure from Motion phase, when that camera 
will be exploited again. 
 

In the previous submenu, you can also load the masks related to photographs, if these 
have been previously generated with the 3DF Masquerade tool. After clicking Next  the 
Masking page will appear(see image above) and it will specify whether the masks have 
been properly loaded into 3DF Zephyr (a green ok should appear close to the picture's 
name, for each imported mask) or not. 
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By selecting the Ignore masking during orientation option 3DF Zephyr will exploit the 
masks only when generating the dense point cloud; this tool is useful if the image 
background is well textured and can therefore help the first phase of cameras orientation. 
 

The next window is the Photos selection page, where user is asked to load the pictures. 
It is possible to drag 'n' drop the files into the window or to click on Add (5)  to select a 
photos directory. 
 

3DF Zephyr allows you to import both images and videos through the Import from video 
images button (6); this tool can divide videos in frames which are treated as photographs 
in the end. 
 

 
 

In the loading window it is possible to select the desired file and then to specify the 
destination folder where it will save the set of extracted frames. In the options below you 
can set the frame rate to be extracted (FPS), the blur analysis on each frame and the 
threshold of identification, and rejection, of similar frames. 
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To start the extraction, simply click on Extract frames and import in the workspace (7). 
 

 
 

After loading the images or video files and clicking on Next button, you will see the 
Camera calibration page where you can notice a list of every single imported image as 
well as the calibration that 3DF Zephyr will use for each camera and its Exif data. 
 

By clicking with the right button of the mouse you can select or deselect all the images, 
and clone calibrations. 
 

From this page, you can Add a New Calibration (8), or Modify the Calibration (9) that 
3DF Zephyr has automatically identified thorugh the Exif data of the photographs. 
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In the Modify Calibration page, you can select the focal lenght you want to change (if 
loaded pictures have been taken with different focal lengths) and then define the 
calibration parameters. 
 

By the Import parameters from file button you can load a calibration files already 
created with an external application (see Lapyx 3DF). 
 

TIP: If you have imported pictures taken with wide-angle or fish-eye lenses it is 
recommended to activate the Adjust tangential distortion parameters option (10) 
 

Once the calibration step has been completed you have to set-up the first phase of the 
3D reconstruction by means of the Camera orientation settings page, which will 
generate a sparse point cloud as initial 3D result. 
 

There are three settings way for the first three  phases of 3D reconstruction (only in 
Zephyr Pro and Aerial): 
 

  - Categories and Presets: is the fastest way to set the parameters of the 
reconstruction; 
 

  - Advanced Mode: allows you to define every detail of the 3D reconstruction phases; 
 

  - XML File Import: allows you to load an XML file where the user has already defined 
the most suitable parameters for its own reconstruction (recommended for professional 
users); 
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Versions presets 

 

It is possible to use categories and presets, advanced mode and import XML files in 
every stage of the 3D reconstruction whether what has been exploited in the previous 
phases or not. 
 

Cameras orientation 

The first phase of 3D reconstruction is called Structure from Motion and it is in charge of 
defining the position and orientation of each photo that has been loaded in Zephyr. That 
step yields a sparse point cloud as initial 3D product. 
 

 
 

Depending on the selected category it is possible to choose among four quality values 
(fast - default - deep - exhaustive) that gradually increase the capabilities of Samantha 
algorithm managing this first phase. 
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You can switch to advanced mode to define each parameter of Structure from Motion 
phase in detail. To do so, simply select "Advanced" from the "settings" dropdown menu. 
 

 
 

Keypoints Density: keypoints represent the matched pixels in the pictures. This 
parameter allows to set the amount of keypoints that 3DF Zephyr will have to extract for 
each photo; nevertheless a substantial amount of keypoints does not lead to a better 
result, since the more the elements involved  the higher the ambiguity during 
correspondences detection between the keypoints themselves. 
 

Very low:  extracts up to 2,500 keypoints per image 

Low:   extracts up to 5,000 keypoints per image 

Medium:  extracts up to 7,500 keypoints per image 

High:   extracts up to 10,000 keypoints per image 

Very High:  extracts up to 15,000 keypoints per image 

 

It is recommended to decrease keypoints density when: 
 

  - it is required a high computing speed; 

  - the distance between cameras and subject/scene on survey does not change; 

  - pictures get a high percentage of overlap (70% - 80%); 
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It is recommended to increase keypoints density when: 
 

  - Cameras are not correctly oriented; 

  - There are some pictures too close and too far from the subject/scene; 

  - The dataset counts a few photos that have a low percentage of overlap; 

  - The subject/scene has a uniform surface and no texture (a white wall for instance); 

 

Matching Type: allows to select different kinds of matches between the keypoints in the 
images. The accurate option requires more time to be completed; 
 

Matching Stage Depth: set-up how many matches  are performed on the images 
between the keypoints. By setting this parameter to the higher value, the capability to 
align multiple images at the same time is going to increase just like computation time. 
 

It is recommended to decrease the depth value of the matching stage when: 
 

 - it is required a high computing speed; 

 - The distance between the camera and subject is not high; 

 - The overlap percentage between different shots is high (70% - 80%); 

 

It is recommended to increase the depth value of the matching phase when: 
 

 - Cameras are not correctly oriented; 

 - There are some pictures too close and too far from the subject/scene; 

 - The dataset counts a few photos that have a low percentage of overlap; 

 - The subject/scene has a uniform surface and no texture (a white wall for instance); 

 

Reprojection Error Tolerance: it checks the maximum reprojection error allowed (in 
pixels) for each point during geometrical reconstruction step and the minimum number of 
points required to merge two clusters of images together. By selecting strict option it is 
possible to get a more accurate reconstruction while wide option increases the chance to 
orient the cameras which would otherwise be discarded. 
 

It is recommended to reduce the reprojection error tolerance when: 
 

 - Reconstruction is not able to converge; 
 

It is recommended to increase the reprojection error tolerance when: 
 

 - Not all cameras are properly oriented; 
 

Bundle Adjustment: it is a nonlinear minimization procedure that corrects points and 
cameras positions while minimizing the reprojection error of each point: it is performed at 
the end of each merge and a further Bundle Adjustment run at the end the procedure. If 
you are working with huge datasets you'd better choose  local and restrained option. 
 

Photo Ordering: this parameter suggests the software which was the photographic 
capture applied on field and therefore the sequence of the pictures taken . That way can 
speed up the near images detection process. By using sequential option the photos 
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have been taken following a numerical order (photo 1 near photo 2 -  photo 2 near photo 
3 and so on), while circular option indicates a loop sequence. If you are aware that the 
photos have been taken with a specific order, you can streamline the process by 
choosing among those two options, otherwhise you can consider the sparse option. The 
last option is called approximate grid and it was designed for data acquisition collected 
from drones or UAV systems, and  it is exploited when capture is sequential and has a 
high percentage of overlap between the pictures (70% - 80%). 
 

A further description of those parameters is available here: http://www.3dflow.net/3df-
zephyr-parameters-tuning-guide/ 
 

You may also switch to the "Custom" mode by selecting "Custom" from the "settings" 
dropdown menu. This mode allows to fine tune in detail every single reconstruction 
parameter. Remember that you can load an XML file or reset to default by right-clicking 
and selecting the desired option. Please also note that a hint regarding the selected 
parameter is shown at the bottom of the window. 
 

 
 

At the end of the first phase of cameras orientation you will see both the sparse point 
cloud and the pictures sequence around the point cloud. 
 

Photographs in the render window are identified by blue stylized cones whose graphics 
are editable in Zephyr Options. 
 

 

Extracting a dense point cloud 

http://www.3dflow.net/3df-zephyr-parameters-tuning-guide/
http://www.3dflow.net/3df-zephyr-parameters-tuning-guide/
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To start the process simply click on Workflow > Dense Point Cloud Generation (11) or 
click on the corresponding icon in the toolbar. 
 

 
 

Tip: Before starting the generation, it is possible to restrict or vary the reconstruction area 
by changing the Bounding Box (12). This step is an optional one as the Bounding Box is 
automatically generated. Anyway by restricting the reconstruction area to the your 3D 
object you can improve the results and speed up the computation time. 
 

Just like the first phase of cameras orientation  this second phase of the  3D 
reconstruction can be set-up by using categories and presets, or switching to the 
advanced mode. The items are explained below: 
 

http://www.3dflow.net/3df-zephyr-parameters-tuning-guide/
http://www.3dflow.net/3df-zephyr-parameters-tuning-guide/
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 Output Type: raw method returns only 3D points with real 2D matches in the images, 
while the other two optimizations exploit some filters  in post-production to make the 
point cloud cleaner and denser. These filters are designed to keep sharp edges (that 
is quite helpful when you have to deal with buildings or interiors for instance)  or 
smooth edges (terrains, human bodies, etc.) 

 

 Number of nearest cameras: the amount of cameras used to create depth maps that 
is also linked to the amount of pictures taken. You'd better increase that value if you 
guess that there are N photos, for each camera, those are aiming at the same point of 
the scene. Increase the number of cameras may increase the processing time. 

 

 Resolution: it defines the resolution used for the pictures. A higher resolution keeps 
more details, but it may produce noisy results if the photos quality is low. The time 
required for the dense point cloud generation is strictly related to this parameter. 

 

 Noise filtering: low values will produce much denser clouds with noisy areas though, 
whereas high values will produce cleaner clouds with less endpoints. 

 

 Depth maps hierarchical Levels: it calculates depth maps at gradually increasing 
resolutions. It is recommended to keep this value at default. 

 

 Discretization Level: allows to Control the level of discretization of the bounding 
volume. A low value will produce a less dense point cloud even if it will make the 
process tougher to noise, whereas a higher value will keep the detail although the 
point cloud will be more exposed to reconstruction noises (if there are low-quality 
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photos for instance). Notice that using high value settings will affect your hardware 
memory. 

 

 Voting type: calculate a hierarchy for the dense point cloud when noise reduction is 
applied. It is recommended to select the hierarchical option. 

 

 Shape from Silhouette: it is an image-based modeling technique that uses the 
profile, or silhouette, of the subject to create a virtual hull containing the subject. You 
must create the masks for all the pictures before running that. This technique can be 
quite worthwhile when you need to deal with transparent or reflective surfaces which 
can not be removed with 3DF Masquerade. 

 

Once the parameters are chosen  you can start the process by clicking on Run button. 
 

The dense point cloud generation requires the most of hardware capabilities along with 
the cameras orientation phase. 
 

Don't forget that you can reconstruct and add more dense point clouds in the same 
Zephyr project even exploiting different parameters or reconstruction volumes. 
 

A further description of the parameters above is available here: 
http://www.3dflow.net/3df-zephyr-parameters-tuning-guide/ 
 
 

Extracting a surface 

Click on Workflow > Mesh Extraction (13) to start the mesh generation phase. 
 

 
 

In the new window  you need to select  the dense point cloud you want to exploit to start  
the mesh generation (14). That is because you can create more dense point clouds in 
Zephyr. 
 

http://www.3dflow.net/3df-zephyr-parameters-tuning-guide/
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In the following page you can see the reconstruction settings. You can choose if select 
categories and presets or enter the advanced setup mode (for  Zephyr Pro and Aerial 
users) as in previous phases of reconstruction. 
 

 
 

 Polygon count (only for smooth reconstruction type): it checks the discretization 
parameter during the surface reconstruction. You should increase this value when you 
want to keep a high mesh detail. Decreasing this value can be helpful when: 

 

 - You do not have enough memory on your pc; 

 - You get noisy results; 

 - You need a low-poly surface; 

 

 Smoothness: allows to define the smoothness of a mesh. You'd better increase this 
value when you get noisy results and decrease it to preserve higher details. 

 

 Reconstruction Type: it is in charge of edges management and you can pick the 
final output (smooth or sharp shape) of surfaces edges. 

 

 Number of minimum / maximum vertices: this step starts after the mesh generation 
algorithm and it does not add detail to the output mesh: when the option is 
activated a simplification (or densification) is performed so as to get the desired 
number of vertices. 

 

You can start the mesh reconstruction by clicking on Next and then on Run button. 
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Timing may vary depending on the total amount of polygons you have previously 
selected. 
 

You can create several surfaces in the same Zephyr project using different parameters. 
 

A further description of the parameters above is available here: 
http://www.3dflow.net/3df-zephyr-parameters-tuning-guide/ 

Texture generation 

In the last fourth phase of 3D reconstruction of Zephyr it is possible to start the texture 
generation on a 3D model by clicking Workflow > Textured mesh generation (15). 
 

 
 

In the settings window (16) the user can set-up the following parameters: 
 

 Texture Size: sets the pixels size of photographic textures. 
 

 Maximum number of vertices: defines how many vertices of the mesh are involved 
in the texturing generation. 

 

 Maximum number of cameras per triangle: manages color calculation of each pixel 
of the texture. It is recommended to keep one camera per triangle activating color 
balance as well (we will get back on this conversation when we will talk about 
orthophoto generation). 

 

 Select the cameras to use: allows the user to establish how many cameras should 
be exploited in the texture generation. All the photos are selected by default. 

 

Since Zephyr 2.0 there is the new automatic color balance algorithm that allows you to 
select and set automagically the best color for each pixel even on different light 
conditions. 

Project Panel 

The Project panel is located in the left sidebar of the main Zephyr interface. This panel 
gathers the most important parts of the .zep file. 

http://www.3dflow.net/3df-zephyr-parameters-tuning-guide/
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In the "Camera" section you can find thumbnails of the images imported in Zephyr, both 
those that were successfully oriented and those who failed the orientation step. By 
double clickining with the left mouse button on a thumbnail the properties window will 
appear with: 
 

 information about the resolution and the position in the Zephyr coordinates system 

 internal calibration parameters 

 statistics about the keypoints that Zephyr managed to find during the SfM phase and 
the mean reprojection erroramere, e l'errore medio di riproiezione della fotografia; 

 

By right clicking one or more pictures it is possible to: 
 

 try again to re-orientate the cameras that have not been orientated 

 see the picture as an overlay, by changing the point of view 

 see the picture thumbnail at a bigger resolution 

 rotate and rename the camera thumbnail 

 change the camera picture file 

 change the mask linked to the camera 

 open the properties window 

 export external and internals parameters of the cameras 

 export the undistorted images 

 

The Sparse Point Cloud, Dense Point Cloud, Meshes and Textured Meshes sections 
all allow to access the properties of the reconstructed 3D object (doublie click with the left 
mouse button) which will show: 
 

 statistics about the point cloud/mesh with the total number of points/polygons 

 information about the generation  process of the cloud/mesh (settings, running time, 
Zephyr version, generation date and time) 

 detailed data about the reconstruction settings as they can be used in .xml files 

 the log file about the reconstruction phase 

 

Tip: in the sparse point cloud properties you can find the Mean Square Error, which 
shows the quality of the reprojection in the orientation phase. As a rule of thumb, when 
this value is lower than 1 then the orientation can be considered valid and you can 
proceed with further steps. With values higher than 1, you may want to execute again the 
orientation phase by: 
 

 excluding pictures with a very high reprojection error (you can find that value in the 
properties of each single camera) 

 adding control points on the images, exporting them, and then using them as 
constraints in the first phase. 

 
 

By right clicking the generated sparse point cloud it is possible to: 
 

 rename the sparse point cloud 

 reset the bounding box volume 

 export the sparse point cloud 

 view the sparse point cloud properties 

 

By right clicking the generated dense point cloud it is possible to: 
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 rename the dense point cloud, clone it or delete it 

 export the dense point cloud 

 see confidence information (3DF Zephyr Pro and 3DF Zephyr Aerial only) 

 view the dense point cloud properties 

 

By right clicking the generated mesh it is possible to: 
 

 rename the mesh, clone it or delete it 

 export the mesh 

 compute the mesh volume (3DF Zephyr Pro and 3DF Zephyr Aerial only - the value 
will be saved in the mesh properties) 

 view the mesh properties 

 
 

By right clicking the generated textured mesh it is possible to: 
 

 rename the textured mesh, clone it or delete it 

 export thetextured  mesh 

 view the textured mesh properties 

 

3DF Zephyr Aerial also fatures the Drawing Elements subsection, which will contain 
sections, contour lines or vector graphics. 
 

By right clicking a generated drawing element it is possible to: 
 

 rename the drawing element 

 change the color of the drawing element 

 export all the drawing elements or those visible/selected 

 access the drawing element properties 

Keypoints animator panel 

The Animation panel is located in the left sidebar of the main Zephyr interface. This 
function allows to easily create demonstration videos of your own models directly from 
the Zephyr interface, allowing you to export the video in the most common file formats 
(avi, wmv) or by uploading them directly to YouTube. 
 

In order to create an animation simply reveal the "Keypoints nimator panel" and click the 
"Add Current Position" button, while simultaneusly moving the workspace camera to 
the desired position. By enabling the "show keyframes" option, every keypoint set will 
be shown in the workspace with a yellow cone shape. 
 

When all the keyframes have been placed you may click the "Play Animation" button to 
see the animation preview, or you may edit the duration of each movement between the 
keyframes by right clicking and editing every keyframe or of the whole animation by 
clicking the "Set Animation Time" button. 
 

By clicking the "Start Video Recording" Button a new window will appear (as soon as at 
least two keyframes have been defined) which will allow you to edit the movie generation 
settings: the parameters that can be edited are the video resolution, the framerate, the 
target bitrate and the final type of the output (on hard drive, youtube, or both) 
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Control Points panel 

 

These functions are available only in 3DF Zephyr Pro e 3DF Zephyr Aerial. 
 

Please note that every reconstruction is generated with an arbitrary scale, translation and 
rotation. This chapter will focus on definind a global scale in order to take measurements 
and align the world position, rotate and translate according to user defined control points. 
 

Control points, aligment and world scaling with known control points (or known distances) 
can be managed from the panel on the right labeled "Control Points". 
 

Picking a control point on the scene 

 

The easiest way (albeit the less accurate) to insert a new control point is to directly pick it 
from the 3D reconstruction. 
 

From the "Control point" panel (1) click the "Pick control point" button (2). The mouse 
cursor will show a crosshair: move in on the scene (3) and left click the desired control 
point position. A new control point will be added to the control points list (4) and will be 
automatically shown in the scene.unti di controllo (4) e sarà automaticamente 
visualizzato nella scena. 
 

This control point selection mode can not be done on a textured mesh. 
 

That's it! That's all you need to do to directly pick a control point! 
 

 
 
 

Picking a control point from images 

 

A much more accurate way to add control point is to pick them directly from the photos. 
You need to pick the same coordinate on at least two pictures in order to triangulate and 
make zephyr calculate the control points. 
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Lets clear the previously created control points by right clicking on the Point List and left 
clicking on “remove all”. Click Yes to confirm. 
 

Now, from the “Control Point and distances Dock menu” click “Add Control Point From 
images” (1): the “Control Point Picker window” will appear. From the “Camera List” (2) left 
click a picture to view it in the “Control Point Picker Selector”. The first selected image will 
be highlighted by a red border (3).  Left click where you want the control point to appear 
and a red dot (5) will appear. The “Ok button” won’t be clickable yet: remember, we need 
at least two images to define a control point in the 3D world. 
 
 

Click on another image in the "camera list" (2): this time also the epipolar line will appear 
(highlighted by the color inversion in the picture) which will help positioning the second 
coordinate by left clicking. The current image will be highlighted by a yellow border (4). 
The "Ok" button will now be clickable - it is possible to add as many coordinates as 
wanted (usually, the more coordinates the better the accuracy) and click OK to complete 
the control point selection. When changing the 2D position, you can see in real time the 
global reprojection error and the local reprojection error. 
 

The light blue border will highlight the camersa with a direct view on the selected control 
point while the dark blue border willl hight cameras that may show the control point as 
occluded. 
 
 

 
 

 

The "Pick and edit control point" function 

 

From the same menu where "Add control points from images" and "pick control point" it 
possible to find also the "Pick and edit control point" button: this function allows to select 
a control point by directly picking it on the scene (exactly like the "Pick control point" 
function) and then modify the position of the control point by editing its position with the 
"add control point from images" interface, with the control point already in place in all the 
possible cameras. 



3DF Zephyr 

29 / 61 

 

The "Import control points" function 

 

Importing control points from text files allows to automatically add control points exported 
from other applications: in order to do that, simply click on the "import control point" 
button, pick the desired text file and then clik "Open". 
 

A window will appear to confirm that the import phase has been completed successfully: 
click OK. 
 

Note: for each imported control point it is necessary to define at least two 2D images 
coordinates. For example, to import a control point named "point1" seen by the cameras 
"PictureA.jpg" at the (x,y) coordinates 100,600 and from a second camera "PictureB.jpg" 
with coordinates (x,y) 200,660 the file has to be formatted in the following way:l file dovrà 
essere formattato nella maniera seguente 

 

Point1 PictureA.JPG 100 600 

Point1 PictureB.JPG 200 660 

 

The "Export Data" function 

 

Just below the "pick and edit control point" button it is possible to access the control point 
(and distances, defined in the "measurements" etab) export function. 
 
 

 
 

From this window it is possible to export: 
 

 2D coordinates 

 

Will create a *ControlPoitns2D.txt file - defines the control points as 2D images 
coordinates, as  
 

"controlPoint1" "IMG_3319.jpg" 4.33473658e+03 2.24061730e+03 

"controlPoint1" "IMG_3320.jpg" 3.30352087e+03 2.42468881e+03 

"controlPoint2" "IMG_3319.jpg" 3.01642756e+03 3.16114630e+03 

"controlPoint2" "IMG_3320.jpg" 1.68567672e+03 2.14786953e+03 

 

 3D Coordinates 

 

Will create a *ControlPoints3D.txt file - defines the control points as 3D coordinates, as 
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"ControlPoint" 8.18880729e-01 -5.14516149e-01 4.54143586e-01 

"Control Point #2" -5.64690812e-01 -5.65085273e-01 1.09244112e+00 

 

 Distances 

 

Will create a *ControlPoints3D.txt file - defines the distances as seen in the 
measurements tab, as 

 

"Control Point #2" "Control Point" 2.33824531e+01 

 

The "scale model with control point" function 

 

Just below the "Export data" button it is possible to find the "scale model with control 
points" function. 
 

 
 

By defining at least three constraints (1) it is possible to scale the model using the 
mentioned control points. 
It is possible to either directly set constraints from text file via the "Import 
constraints from file" button or manually. Please note how each control point can 
be set as Control point, Constraint, or both by using the checkboxes on the left of 
each point. 
 

It's  always a good idea to include some control points that are not set as constraints . 
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3DF Zephyr Aerial also shows another option, which is the ability to directly change the 
reference system (2). 
 

You may also perform a bundle adjustment by checking the "perform bundle adjusment 
checkbox" (3). This can be done by using a slider that will assign a confidence weight in 
the defined constraints, as well as an advanced mode option. 
 

Click OK to proceed. 

Measurements panel 

 

These functions are available only in 3DF Zephyr Pro e 3DF Zephyr Aerial. 
 

Control distances can be defined as the distance between two control points , the 
distance between a control point and a camera, or the distance between two cameras. 
With 3DF Zephyr you can easily define control distances and even scale the world with 
control distances. 
 

The "Add control distance" function 

 

To add a new control distance, click on the “Add Control Distance” Button (1). The 
“control point selection window” (2) will pop up. From this window, pick the two control 
points needed from the Control Point #1 selection menu and the Control Point #2 
selection menu . Once you click “OK”, the distance will be drawn as a green line (3) and 
rendered onto the screen (in this case, 2.18197). 
 

The control distance (and the relative used control points) will also appear as a list on the 
rightside panel (4). 
 

 
 

The "Scala world with control distances" function 
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It is possible to scale the model using control distances: in order to do so, simply click on 
the "Scale world with control distances" button: in the window that will popup, simply set 
the wanted distances as constraints. When completed, the residue error will be shown. 
 

The "mIport control distances from txt" function 

 

It is possible to import control distances directly from text file: every line of the text file 
must be formatted as 

 

"Control Point #2" "Control Point"  2.18197 

 

The "measure mesh volume" function 

 

It is possible to compute the mesh volume using the dedicated button. If the mesh is not 
completely closed, all holes will be automatically filled and later shown with a red color - it 
is possible to save that mesh as a separate workspace object. 
 

If you decide to use a point cloud as a source, it will be computed the corresponding 
mesh anwyays. 
 

Once you have selected the reference mesh from the menu, simply click the "Compute" 
button. 
 

La "measure mesh area" function 

 

Similarly to the "measure mesh" function, clicking this button will compute the area of a 
given mesh. Just select the mesh and click the "Compute" button. 
 

The "Angle measurements" function 

 

When at least three control points have been selected, you can compute the angle 
between control points. The interface of the window that will appear will allow you to set 
control points as A,B and C and then compute the angles between the vectors BA and 
BC. A checkbox will allow to change the output to radiants or degrees. 

Drawing panel 

 

These functions are available only in 3DF Zephyr Aerial. 
 

Fromt he "Drawing" tab it is possible to create drwaing elements directly on the 3D 
model, which then can be exported into .DXF or .SHP. 
 

To create a new drawing elemnt, simply click the "Create new" (1) button - the new 
element will be automatically added to the "Drawing elements" section in the Project tab 
(2). 
 

Once an element has been created, the dropdown menu to select the current drawing 
element will be enabled (in this case, showing the only available drawing element, 
"Drawing Eleemnt 0", just below the "Create new" button). This allows to select and edit 
previosuly created drawing elements. 
 

When the drawing element has been selected, it is possible to navigate the scene to the 
deisred position (eventually by making use of the "align orthographic camera" checkbox). 
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When ready, it is possible to select the middle points that will define the shape of the 
drawn element, by picking them directly on the mesh using the "Select" button (3). You 
may also use the "continous mode" checkbox that won't ask for many clicks (each for 
every middle point) but instead it will draw the line as long as the left click is kept pressed 
and the cursor is on top of the mesh. 
 

Press "ESC" to exit the drawing mode. 
 

It is possible to change the color of one (or more) drawing elements by selecting the 
desired elements from the "drawing elements" section in project tab (2) by right clicking 
on the selection and then selecting "Change color selected" 

 

 

The "Workflow" menu 

The workflow menu allows to undertake major actions within the 3D reconstruction 
workflow, such as starting a new project, completing a reconstruction step or adding 
photos. 
 

The "New Project" function 

 

By clicking "New project" the current workspace will be cleaned and ther new project 
wizard will appear, as shown earlier in the "Starting a new project" chapter. 
 

The "Dense Point Cloud generation" function 

 

Starts a new dense point cloud generation wizard. See the "Extracting a dense point 
cloud" chapter as reference. More than one dense point cloud can co-exist in the same 
workspace. 
 

The "Mesh extraction" function 

 

Starts a new mesh extraction wizard. See the "Extracting a surface" chapter as 
reference. More than one mesh can co-exist in the same workspace. 
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The "Textured mesh extraction" function 

 

Starts a new texture mesh extraction wizard. See the "Extracting a surface" chapter as 
reference. More than one textured mesh can co-exist in the same workspace. 
 

The "Add photos" function 

 

This process allows to add photos to the current workspace. The photos has to be taken 
with one of the cameras already used in the original workspace. The "Add photos" dialog 
is similar to the "New project" wizard, so you simply have to add photos by browsing or 
by drag and dropping them. After the new photos have been selected, the following 
dialog will appear: 
 

 
 

All that is required to do, is to simply select at least one camera on the left panel (by left 
clicking it) which is near to the photos that you want to add. If the photos can be added to 
the workspace correctly, you will see them in the "Cameras" section and the "Sparse 
point cloud" will be replaced with the new one, computed using the new cameras in the 
workspace. Any other workspace element (such as dense point clouds and meshes) 
won't be affected automatically by this action. 
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The "Export" menu 

The export menu allows to export different elements from the workspace as standalone 
files (for example, an obj file) or to other services (for example, the direct upload to 
Youtube). 
 

The "Export cameras and points" function 

 

This function is available only in 3DF Zephyr Pro e 3DF Zephyr Aerial. 
 

This function allow to export cameras (internal and external parameters for each camera 
- one text file for the externals and one text file for the internals) giving different options to 
the advanced user, such as the option to export the projection matrices for OpenGL, the 
points visibility and the option to export the sparse point cloud (in PLY format) and to 
generate the undistorted images. 
 

La "export dense point cloud" 

 

This function is available only in 3DF Zephyr Pro e 3DF Zephyr Aerial. 
 

This function allows to export the generated dense point clouds into different file formats. 
 

The first option in the export dialog allows to select the desired dense point cloud, since 
more dense point cloud can coexist in the same workspace. 
 

The "Export format" option allows to select the desired export format - it is possible to 
export directly into .ply, .pts, .ptx, .xyz, .txt, .las, .e57 and to the 3D visualization web 
service Sketchfab. By selecting certain formats, some advanced options may or may not 
be enabled 

 

The "Export colors" option (if selected and for the supported formatas) allows to export 
the point colors. 
 

The "Export normals" option (if selected and for the supported formatas) allows to export 
the normals 

 

The "Use binary encoding" option (if selected and for the supported formatas) allows to 
export in binary mode (or in text mode if not selected) 
 

The "Decimate" option (if selected) allows to automatically decimate the dense point 
cloud point number up to the desired value (as defined by the Max point cloud option) 

 

The "Local rendering reference system" option (if selected and for the supported 
formatas) allows to export by using the local rendering reference system 

 

The "Export mesh" function 

 

This function allwos to export the generated meshes into different file formats. 
 

The first option in the export dialog allows to select the desired mesh, since more meshes 
can coexist in the same workspace. 
 

3DF Zephyr Lite allows to export to .ply, .stl, .obj/mtl and and to the 3D visualization web 
service Sketchfab. By selecting certain formats, some advanced options may or may not 
be enabled. 
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3DF Zephyr Pro and 3DF Zephyr Aerial allow to export (in addition to the format exported 
by 3DF Zephyr lite) also to the .fbx, pdf3df, Universal3D and Collada file formats. Please 
note that the fbx format also allows to export the camera positions. 
 

The "Export normals" option (if selected and for the supported formatas) allows to export 
the normals 

 

The "Use binary encoding" option (if selected and for the supported formatas) allows to 
export in binary mode (or in text mode if not selected) 
 

The "Export cameras" option (only for Zephyr Pro and Zephyr Arial, if selected and for the 
supported formatas) allows to save the camera positions. 
 

The "remesh before exporting"  option (if selected) allows to execute a remeshing 
algorithm, which will generate a new mesh with a vertices count as higher as the number 
defined by the user. 
 

Eventually, it is possible to already create the mesh at this point. However it is usually a 
good idea (for a more manageable workflow) to extract also the texturized mesh in the 
workspace. Please see the "Extracting the textured mesh" chapter for more information 
about the available options. 
 

The "Add comment" option (if selected and for the supported formatas) allows to add a 
text comment as file metadata. 
 

The "Export textured mesh" function 

 

This function allwos to export the generated textured meshes into different file formats. 
 

The first option in the export dialog allows to select the desired textured mesh, since 
more textured meshes can coexist in the same workspace. 
 

3DF Zephyr Lite allows to export to .ply, .obj/mtl and and to the 3D visualization web 
service Sketchfab. By selecting certain formats, some advanced options may or may not 
be enabled. 
 

3DF Zephyr Pro and 3DF Zephyr Aerial allow to export (in addition to the format exported 
by 3DF Zephyr lite) also to the .fbx, pdf3df, Universal3D and Collada file formats. Please 
note that the fbx format also allows to export the camera positions. 
 

The "Export normals" option (if selected and for the supported formatas) allows to export 
the normals 

 

The "Use binary encoding" option (if selected and for the supported formatas) allows to 
export in binary mode (or in text mode if not selected) 
 

The "Export cameras" option (only for Zephyr Pro and Zephyr Arial, if selected and for the 
supported formatas) allows to save the camera positions. 
 

The "Add comment" option (if selected and for the supported formatas) allows to add a 
text comment as file metadata. 
 

The "Export control points" function 
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This function is available only in 3DF Zephyr Pro e 3DF Zephyr Aerial. 
 

This button opens the same dialog that the "Export data" button exposes from the 
"Control point" panel. 
 

The "Export workspace" function 

 

This function is available only in 3DF Zephyr Pro e 3DF Zephyr Aerial. 
 

This function allows to export the workspace to .ply/text files. 
 

The "Export processing report" function 

 

This function is available only in 3DF Zephyr Pro e 3DF Zephyr Aerial. 
 

This function will create a pdf report about the current workspace - the report will contain 
information about the workspace, from the sparse point cloud to the textured mesh, with 
a technical summary and statistics. 
 

The "Export current view as PDF" 

 

This function allows to create a screenshot of the workspace current view, as PDF file. 
 

The "Take screenshot" function 

 

Like the "Export current view as PDF" function, this function allows to create a screenshot 
of the vurrent view, as an image file. Few additional options are available, such as the 
possibility to have a transparent background. 

The "Edit" menu 

From the "Edit" menu it is possible to quickly access the classic "Undo" (CTRL+Z) and 
"Redo" (CTRL+Y) actions. 
 

Not all actions in Zephyr support undo/redo. 
 

The command history can be seen from the "History" panel. 
 

Another submenu labeled "Select" allows to apply certain functions on the workspace 
elements - most of these commands have a direct quick button on the main toolbar. 
 

Select all: selects all the currently active subject in the workspace - triangles for meshes, 
points for clouds. The selected part will be highlighted by a red color. 
 

Invert selection: invert the previously done selection. The selected part will be 
highlighted by a red color. 
 

Enable/Disable point selection mode: allows to select a part of the currently active 
object in the workspace - the selection is made by considering all the points contained by 
dragged rectangle in the workspace (keeping the left-click button pressed) - when the 
click is released, the selection will be done. The selected part will be highlighted with a 
red color. 
 

Enable/Disable polygon selection mode: allows to select a part of the currently active 
object in the workspace - the selection is made by considering all the points contained by 
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a polygon defined by clicking and connecting the polygon points in the workspace - when 
the polygon is closed, the selected part will be highlighted by a red color. 
 

Delete selected items: deletes the currently selected (those element which are 
highlighted in red) from the currently active object. 
 

Select by color: selects (on dense point clouds) all the points of a given color (within a 
given threshold) 
 

Select by plane: selects a part of the currently active subject  - the selection is done by 
placing a plane that will "cut" the subject - all points above that plane will be selected. 
The selected part will be highlighted with a red color. 
 

New object via copy: creates a new object in the workspace, by making a copy of the 
current selection. 
 

New object via cut: creates a new object in the workspace, by cutting the selected 
object. The inverse of the selection will become the origin object. 

The "Scene" menu 

This menu allows to manage how the subject is rendered and how the bounding box is 
defined in the scene. 
 

Most of these functions have a quick access button on the main toolbar. 
 

Camera management via the "Camera" menu 

 

Zephyr allows to navigate the scene in three different ways: 
 

 Orbit: in order to navigate the scene in "orbit" mode the mouse cursor has to be on 
scene: keep the left mouse button pressed and move the mouse to orbit around the 
subject. To zoom in or out, keep pressed the left shift button and move the mouse 
forward/backwards. The pivot is centered as the center of the bounding box. 

 Orbit with pivot: like orbit, however the pivot will be moved where the mouse cursor is 
at the time of the left click button press. 

 Free look: "first person shooter" view where the movement is applied via the WASD 
buttons (W forward, S backwards, A left, D right) and Q/E (up,down). 

 

The "Orthographic projection" camera mode can be toggled via the dedicated checkbox. 
 

Finally, there are few buttons that allow to move quickly into predefined position with 
respect to the subject (move left, move up, etc.) and a reset camera button. 
 

Rendering management 
 

Zephyr allows to change the rendering settings as follows: 
 

Turn light on/off: toggles the lighting applied to the scene 

 

Show only sparse point cloud: changes the current active workspace object to the sparse 
point cloud. 
 

Show only dense point cloud: changes the current active workspace object to the dense 
point cloud. 
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Show only mesh: changes the current active workspace object to the mesh. 
 

Show only textured mesh: changes the current active workspace object to the textured 
mesh. 
 

Enable/Disable wireframe: toggles the wireframe visualization 

 

Enable/Disable colors : if the lighting is enabled, this can be used to disable the mesh 
color for an easier mesh inspection. Obviously, if the lighting is turned off this option won't 
be enabled as well. 
 

Enable/Disable culling: toggles triangle culling 

 

Enable/Disable volume: shows the computed mesh volume 

 

Bounding box management 
 

When a 3D model is reconstructed by Zephyr, the corresponding bounding box will be 
computed as well. A bounding box is defined as the volume in which all points that do not 
fall into said volume will be discarded. 
 

You can then change how Zephyr behaves by changing the bounding box settings (not 
just for "what" is being reconstructed, but also the discretization level changes when the 
volume changes too) 
 

Show/Hide bounding box: toggles the bounding box rendering in the scene 

 

Translate Bounding box : click and drag the desired gizmo to move the bounding box 
over the selected axis. 
 

Rotate Bounding box: click and drag the desired gizmo to rotate the bounding box over 
the selected axis. 
 

Scale Bounding box: click and the desired face of the bounding box to scale the bounding 
box. 

The "Utilities" menu 

From this menu you can launch utilities: 
 

3DF Masquerade: standalone external tool (included in all 3DF Zephyr versions) to 
create masks to pair with the images to be processed in 3DF Zephyr. A mask is defined 
as a specific selection of one (or more) images that allows to force zephyr to ignore the 
corresponding part in a picture. The first time you run Masquerade useful tooltips will 
appear on the screen that will teach you the interface basics. 
 

You can find a complete tutorial (and videotutorial) about 3DF Masquerade at the URL 
http://www.3dflow.net/en/technology/documents/3df-zephyr-tutorials/tutorial-use-
masking-tool/ 
 

The 3DF Masquerade interface is split in four parts: 
 

 (1) toolbar - select the tool and mask the image 

 (2) top toolbar - rotate images / show mask as black and white 
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 (3) command history - used to undo / redo commands inside 3DF Masquerade 

(4) images list - quickly browse the images  
 

 
 

 

The Rectangle, Polygon and lasso tools are very similar and most users should be 
already familiar with them: to mask a certain area (the area you want to process) you 
can: 
 

- drag a rectangle and click the "mask" button to mask the selected area 

 

- use the left click button to add nodes to the polygon path (doubleclick to automatically 
close the polygon) and click the "mask" button to mask the selected area 

 

- drag the lasso and click the "mask" button to mask the selected area. 
 

When the selection has been made, you should see a blue overlay, while when the mask 
is being applied, you should see a red overlay. 
 

You may also remove a mask subsection using the "remove mask" button. 
 

Using these tools you can add and substract differet ares by keeing the left control/left 
shift keyboard button pressed when doing an action. You may also undo actions using 
the CTRL+Z shortcut or by using the command history. 
 

You may also change the zoom value by using the scroll up/down mousehweel; you may 
also translate the current view by moving the mouse while the mousewheel is kept 
pressed down. 
 

The silhouette tools can be also used to automatically compute the silhouette of the 
subject by tracing the forground element (red, which will be masked) and the background 
element (blue, which won't be masked). You may also quickly swap the 
foreground/background by usinng left shift + left click. 
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You can also delete strokes by dragging the cursor over it and right clicking while 
dragging. 
 

This tools is very useful especially when the background has a very high contrast with 
respect to the subject that you want to reconstruct. 
 

Finally, a gear shaped function allows you to automatically compute the next silhouette, 
very useful especially when dealing with turntables. 
 

Open Sunny: opens 3DF Sunny, 3Dflow's cloud computing service (in beta) 

 

Image Quality Index: shows a numeric value (and visually in Pro and Aerial) the quality 
of the input pictures. You can simply drag and drop the pictures into the quality index 
window, and the score will be automatically computed. Higher score means higher 
quality. Please note that this score is computed per picture: it does not use any 3D 
information or of workspace information - this will simply compute which areas of the 
picture are well in focus and potentially with a high density of keypoints. A high-score 
picture does not automatically means that a picture has been shot correctly, however a 
low-score picture should be discarded (in green are shown the better areas). Double click 
each line to open the visual mode. 
 

 
 

  
 

DEM viewer utility: allows to view .DEM files directly from the Zephyr UI. Please refer to 
the "DEM file and profile generation" chapter for more information. 
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Launch camera calibration: opens 3DF Lapyx, with an easy to use wizard to compute 
the camera calibration. Follow the onscreen instruction if you wish to precalibrate your 
camera. You won't need to print anything: the pattern will be shown on the screen and 
that is what you need to photograph. 
 

Matches viewer: opens the match viewer interface. Simply select an image on the left 
panel by left clicking it and similarly an image on the right panel. After clicking "next", 
keypoints and matches will be shown with a line. between the two images. Simply click 
"back" and repeat the process to see matches from different images. 
 

 
 



3DF Zephyr 

43 / 61 

Batch: available only in 3DF Zephyr Pro and 3DF Zephyr Aerial, the batch processing 
window allows to schedule certain reconstruction jobs. Jobs must be defined via XML 
files, and they must follow the pipeline workflow, at least partially (this means that you 
can setup a job from the sparse point cloud generation to the texture mesh generation, 
eventually stopping at any of the intermediate step, but  you can not define a job that 
starts after a camera orientation). 
 

The xml files must be defined in this format: 
 

<?xml version="1.0"?> 

<Settings> 

 <Category name="Batch"> 

  <Entry key="InputDirectory" value="ImagesInputPath"> 

  <Entry key="OutputDirectory" value="OutputPath/> 

  <Entry key="Phase" value="SamanthaStereo"/> 

  <Entry key="SamanthaPresetCategory" value="Urban"/> 

  <Entry key="SamanthaPresetName" value="Fast"/> 

  <Entry key="StereoPresetCategory" value="Urban"/> 

  <Entry key="StereoPresetName" value="1_Default"/> 

  <Entry key="SurfacePresetCategory" value="Urban"/> 

  <Entry key="SurfacePresetName" value="0_Fast"/> 

 </Category> 

</Settings> 

 

It is also possible to use the custom parameters directly in the XML. A description of hte 
categories and the parameters is available when selecting "Custom" during the 
reconstruction wizards or by selecting the properties (with the right click) of an element 
reconstructed within the workspace. After scheduling one or more job, they will be listed 
int he interface, from where you'll be able to start the batch operations. 
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DEM file and profile generation 

These tools are available for 3DF Zephyr Pro and Aerial versions only. 
 

You are supposed to generate an orthophoto before running DEM generation, so click on 
Tools > Orthophoto and orthomosaic > Generate orthophoto. 
 

You are allowed to choose if either exploiting control points or axis method, then just click 
on Next button. 
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Check the Export section into the orthophoto settings window and activate the Export DEM 
file option (image) 
 

After clicking on Generate orthophoto button simply choose a file name and format as well 
as the file destination. 
 

As soon as the computation is completed the DEM viewer will appear automatically. It 
allows to see the DEM you have just created directly inside 3DF Zephyr. (image) 
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DEM viewer can be run whenever by clicking on Utilities > DEM viewer in the menu bar of 
3DF Zephyr, and it can be exploited to: 
 

  load DEM files (even those not related to the project you are working on) by clicking 
on File > Open; 

 place contour lines on DEM if they have been previously generated in 3DF Zephyr, by 
clicking on View > Show Contour Lines;  

 export DEM as a image format (.png, .jpg, .bmp); 
 

PROFILE GENERATION  
 
In the DEM Viewer it is also possible to run a Profile generation in order to draw one or more polylines directly 
on DEM and getting then their altimetric profile. 
To to draw a polyline on DEM you simply click on Profile > Enable Picking in the DEM viewer window. By 
drawing one or more polylines on DEM you will notice that each vertex will be identified by a number (see 
image below).  
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Once all polyline vertices are placed you can click on Profile > Show info and you can check the tab Points, 
where each vertex of the polyline is listed, and the tab Profile as well, where you can see the altimetric profile 
of the polyline (see image below).  
Moreover, by moving the cursor you can see the quote of every single profile point in detail. 
 

 
 
You can also export a profile (pdf format) by clicking on Export > Profile Report. 
 
 

Tools - Workspace 

The Workspace menu allows to run tools dedicated to the management of the 3D objects 
and to the pictures used in the 3D reconstruction: 
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 Scale - Rotate - Translate world: allows to scale/rotate/translate the 3D models 
(clouds and meshes) 

 

 Define the up vector by selecting two points: allows to draw a segment directly on 
the 3D model to be aligned with the Z axis (basically, the drawing must be done on an 
element of the 3D model that is actually on the up vector in the real world, such as a 
wall in a building) 

 

 Define the up vector by selecting the ground plane: allows to draw a triangle (a 
plane) from which the Z axis will be computed (the plane must be done on an element 
of the 3D model that is actually on the horizontal axis in the real world, such as the 
ground). After picking the second point in the plane, two arrows will be rendered on 
the screen, one that will show the Z axis (blue arrow) and the normal direction of the 
plane (Red arrow). In order to correctly align the z axis, the two arrows must match. 

 

 Define the plane vectors by selecting two axes: allows to select the plane vectors 
by selecting the two corresponding axes. Simply left click the origin point and then the 
second point that will define the first axis. After that, select the second point (from the 
selected origin) that will define the second axis. 

 

 Change workspace images: this tool is very useful when working with thermal or nir 
images: after the 3D reconstruction has been completed using classic RGB images 
from anormal camera, you can swap the corresponding NIR/thermal image and 
everything will behave exactly as the sparse point cloud was made with those images. 

 

 Change Masks: allows to change the maks used for the current dataset 
 

 Camera Stats: shows information about the mean reprojection error and the number 
of points viewed by each camera in the sparse point cloud. 

 

 Camera GPS Coordinates: shows a preview of the GPS coordinates via 
OpenStreetMap 

 

 Enable/Disable confidence: allows to see/hide information about the dense point 
cloud confidence 

 

 Optimize camera parameters: this tools allows to run a further bundle adjustment, in 
order to improve the accuracy of the Structure from Motion algorithm. It's advised to 
run this tool before running the Multi View Stero phase (dense point cloud extraction). 

 

Tip: a typical case in which the bundle adjustment step is requried is when the first 
camera orientation step has completed with a mean reprojection error value above 1: 
after placing at least three control points from the images it is possible to run the 
"optimize camera parameters" step, giving much more weight to the defined constraints. 

Tools - Mesh Filters 

From this menu it's possible to applied the selected mesh filter to a mesh in the 
workspace. 
 

Decimation: select the desired mesh with the dropdown menu and the number of 
desired vertices. The mesh will be regenerated decimating the vertex count to the 
maximum specified value once. 
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Densification: select the desired mesh with the dropdown menu and the number of 
desired vertices. The mesh will be regenerated using the vertex count to the maximum 
specified value once. 
 

Laplacian smoother: will smooth the surface of the selected mesh. Reduces noise and 
won't keep sharp edges. 
 

Bilateral smoother: will smooth the surface of the selected mesh. Reduces noise while 
trying to keep sharp edges where possible. 
 

Fill holes: will fill the mesh holes. From the selection window it is possible to select a 
specific hole (in the workspace scene the hole border will be highlighted with a border) or 
all holes of a certain size (or all holes). The color of the triangles that will close the hole 
will most likely wrong when the missing visibility of the point from the camera will behave 
in a degenerate way (and, obviously, it is impossible to identify the color of something 
that is not seen by any picture). Two algorithms are available, watertight and selective. 
While the selective one can close the selected hole in a fast way, it might not work for 
complex cases, in which case we suggest to you the watertight algorithm. 

Tools - Control points and Distances 

These functions are available only in 3DF Zephyr Pro e 3DF Zephyr Aerial. 
 

This menu allows to access certain control points tools. 
 

Scale model with control points: same functionality exposed in the "Control points" tab. 
 

Scale  with control distances: same functionaly exposed in the "Measurements" tab. 
 

Show last alignment information: shows information about the latest "scale model with 
control points" operation. 
 

Change current coordinate reference system:  allows to change the reference system 
of the project (only 3DF Zephyr Aerial). You must have already defind the reference 
system with control points before you can change the reference system 

Print Markers and markers use 

The following chapter will explain learn how to exploit coded targets in 3DF Zephyr in 
order to further improve the cameras orientation phase. 
 

3DF Zephyr’s coded targets are square-shaped  (see image below). 
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In order to print coded targets just click on Tools in Zephyr’s menu bar and then on 
Control points and Distances > Print Markers. You can print up to 24 different targets. 
 

3DF Zephyr supports 16 bit coded target: their size strictly depends on the kind of 3D 
reconstruction and the related photographic survey as well. 
 

Recommended settings are as follows: 
 

- Close Range and Human Body 4 targets per sheet (A4 size) 
- Urban     2 targets per sheet (A4 size) 
- Aerial     1 target per sheet (A4 or A3 size) 
-  

You can define the amount of targets per sheet by editing the printing menu settings on 
Windows ( the term “page” implies a target inside that menu). 
It is recommended NOT to use coded targets randomly; instead it is highly 
recommended to use them in their own numerical sequence (1, 2, 3, 4, etc. and not 4, 
13, 22, etc.) 
When photographic survey is completed and after the cameras orientation phase is done 
you can start the automatic detection of coded targets by clicking on Tools > Control 
Points and Distances > Detect Markers. 
In the new windows you have to specify: 
 

- Which is the context where coded targets have been exploited (Urban, Close Range, 
Aerial); 

- Which preset (detection quality) you want to run; 
- The amount of coded targets within the scene; 

 

After clicking the confirmation button, 3DF Zephyr will start the automatic target 
recognition and will set the control points based on the detected targets. 
 

Please note that the automatic target recognition has to be started AFTER having 
completed the camera orientation phase in Zephyr. 

Tools - Sections and Contour Lines 

Sections and contour lines generation tool is only available in Zephyr Aerial. 
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By clicking on Tools > Sections and Contour Lines you can select the drawing element 
you want to create choosing among: 
 

 single section: this tool generates only one plane that you can move, rotate and 
resize; the position of the plane can also be modified using the control points, if they 
have been previously placed on the 3D model; 

 

 Track Sections: this tool generates several planes (user can fix the amount of those) 
on each positions of the control points so it is worthwhile when it is necessary to draw 
sections on an irregular path (for example, a river bed); 

 

 Contour Lines: allows to generate one or more contour lines on the 3D model and 
user can choose the reference axis for contour lines direction; 

 

Each one of the tools above leads to a window after the planes have been placed (see 
image below). 
 

 
 

In this window you can draw sections and contour lines previously identified by the 
planes both automatically or manually. In the upper bar of the window there are editing 
and drawing icons as follows (from left to right): 
 

 - Create: manual method that allows you to draw a polyline; 

 - Remove: removes the vertex of a polyline; 

 - Move: moves the vertex of a polyline; 

 - Split: adds vertex to a polyline; 

 - Clear: deletes all polylines; 

 - Close Polylines: closes a polyline; 

 - Smooth Polylines: allows you to smooth all the polylines drawn; 

 - Autocompute Current: generates a polyline only on the section shown in the window; 
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 - Autocompute All: generates a polyline for each section previously created using the 

planes; 

 - Export: allows you to export drawings in dxf and shp format; 

 - Import to Workspace: allows to import drawing elements in Zephyr workspace; 

 

Previous and Next icon allow to scroll among the sections created. 

Tools - Orthophoto and orthomosaic 

These functions are available only in 3DF Zephyr Pro e 3DF Zephyr Aerial. 
 

From this menu it's possible to access the Orhotphoto and Orthomosaic generation 
functions. These functions are available in 3DF Zephyr Pro and 3DF Zephyr Aerial only. 
 

Both this functions allow to select the generation method either via control points (having 
previously defined at least three control points) or via a reference axis. If you pick the axis 
mode, you will later be granted the possibilty to select the desired area via a dedicated UI 
or via control points. 
 

Both these functions exopose a preview of the orhtophoto/orthomosaic directly in the 
scene. 
 

Generate Orthomosaic 

 

The orthomosaic generation requires a dense point cloud in the workspace. After 
selecteing the generation mode in the first wizard page (by control points or by axis) the 
orthophoto generation wizard will appear: 
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3DF Zephyr Aerial will show the current coordinate system (1). 
 

The "Position" subsection (2) (in this example the axis mode has been selected) will 
define the initial and final position of the orthomosaic. You may set the limits via control 
points or by dragging a rectangle with the rubber band tool 
 

You may control the appearance of control points and control distances using the "show 
control poitns and distances in preview"  checkbox. 
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The "Export" (3) subsection allows to export: 
 

 World file (3DF Zephyr Pro and 3DF Zephyr Aerial) 

 Autocad script (3DF Zephyr Aerial) - exports a scr file that will automatically load the 
orthomosaic within autocad, with the correct scale settings set in Zephyr 

 .KML file (3DF Zephyr Aerial) 
 

The Output subsection (4) allows to define the width and height of the output file (thus 
controlling the ground sample distance) 
 

The Advanced subsection (5) allows to control the color generation mode for each single 
pixel. This is system is very similar to the texture generation system. We advise to leave 
the color balance on with 1 camera per pixel. If you wish, you may however use more 
cameras for a different color weight. If this happen, you may choose between a fusion 
algorithm: 
 

blending - will weight the color source depending on the view angle and the distance. 
Although it's robust to lighting changes, the mean won't keep high frequencies. 
 

multiband - will use the mean to to compute low frequencies and the best images to 
compute the high frequences. This is usually a better choice than blending because while 
it is still robust to lighting changes (usuaully just a little worse than blending) by 
preserving the high frequencies the resulting image will be more in focus and sharp. 
 

Generate Orthophoto: 
 

To proceed with the orhtophoto generation you must have generated a mesh first. 
 



3DF Zephyr 

55 / 61 

 
 

Every option in this wizard has the same explanation as the orthomosaic. Please note 
how in this screenshot the control point mode has been selected to define the orthophoto 
plane, and thus the "Position" subsection is slightly differnt, offering parameters such as 
distance, rotation and X,Y positions. 
 

As a last note, it is possible to export the .DEM file in the Export subsection (by 
specifiying the elevation axis) 

Open, Save and Load a project 
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Each project created with Zephyr is saved as .zep format. 
 

Each project file also includes the photographs used for the 3D reconstruction, therefore 
it is possible to open, send and edit the path of zep files which have not to be followed by 
the images. Nevertheless it will not be possible to start one of the four phases of 3D 
reconstruction or make changes involving photographs usage. 
 

Click on File > Open or Open Recent to open a .zep project, or click on Save or Save 
As to save your work. 
 

If you have a command-line reconstruction made with 3DF Samantha, the Structure from 
Motion algorithm, you can import that by selecting File > Load from 3DF Samantha. 
 

Load a file .psz 

 

This function is available in 3DF Zephyr Pro and 3DF Zephyr Aerial only. 
 

Within Zephyr you can be load psz project by clicking on File > Load from .psz file. 
 

Cameras, sparse point cloud and mesh of psz project are imported In Zephyr and you 
can now start  some 3D reconstruction phases such as the dense point cloud or texture 
generation. 
 

Load pictures with the known camera parameters 

 

This function is available in 3DF Zephyr Pro and 3DF Zephyr Aerial only. 
 

In Zephyr you can manually import all the parameters of a camera before starting the  
cameras orientation phase; cameras will be calibrated without being adjusted by 
Structure from Motion algorithm. 
 

To load the parameters just click on File> Load images with known camera 
parameters. 

Merge projects 

In Zephir you can merge two or more .zep projects related to the same scene or subject. 
 

To optimize the procedure it is recommended to generate just the sparse point cloud 
into the projects involved before proceeding with the merge. Once you completed that it 
will be possible to start the following steps of 3D reconstruction. 
 

The photographs of the projects have to share a common area so you can proceed to the 
merge by means of: 
 

 Control points: after clicking on Import > Import and merge another workspace 
you will see the Import window. It is necessary to place at least three control points on 
each point cloud of the projects before running this procedure. Control points must 
have the same position and the same name to allow Zephyr to find matches between 
them and proceed to the merge. It is recommended to keep the Compute Bundle 
Adjustment option active so as to further optimize the merge process. 

 

 Nearby cameras (only in Zephyr Aerial): click on Import > Import and merge 
another workspace to open the Import window where you just select the project you 
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want to merge and click the Import button. If no control points are placed in the 
projects Zephyr will automatically select Use the nearby cameras option. 

 

 
 

In the image above you can see the pictures of current project work on the left side while 
the images to be merged are showed on the right side of the window. Note that the 
thumbnails of images on the right side are displayed in black and white as long as the 
user selects at least one photograph of the group on the left. 
 

First of all you need to select at least one picture in the list on the left, then you have to 
select at least one picture in the list on the right. The most proper pictures to be 
selected focus on a common area of the captured subject or scene. 

Handle laser scanner point clouds 

These functions are available only in 3DF Zephyr Pro e 3DF Zephyr Aerial. 
 

It is possible to import point clouds generated by means of laser scanner equipment, 
orienting them to the clouds generated through Zephyr. 
 

Tip: before using that tool it is necessary accomplish at least the camera orientation 
phase. However it is recommended to perform even the second phase of 3D 
reconstruction and get the dense point cloud. 
 

Once the dense point cloud is generated simply click on Import on menu bar and select 
Import and align point cloud. In the new window you can choose between two different 
alignment methods: control points or SRT alignment. Make sure to follow only one of the 
proposed methods. 
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This procedure is also available at http://www.3dflow.net/technology/documents/3df-
zephyr-tutorials/point-cloud-coloring-using-3df-zephyr/ 
 
 

Control points alignment 

 

Before starting you need to place at least three control points on the point cloud 
exploiting them for the clouds alignment. 
 

After clicking on Import point cloud button and choosing your data simply select Align 
with Control points and click on Next button. 
 

File formats available are the following: 
 

 - ply 

 - txt 

 - xyz 

 - ptx 

 - pts 

 - las 

 

Note that the imported cloud is immediately shown into Zephyr workspace. 
 

 
 

In the next window you can activate the decimation tool if the imported cloud contains a 
considerable amount of (million) points. This tool is disabled by default. Click on the Next 
button to continue. 
 

When checking the following window in the image above you will notice that it is arranged 
in three sections: 
 

 Control points Management section allows you to place  the corresponding control 
points one by one on laser scanner cloud and to link them to the points previously 
identified on the dense cloud generated with Zephyr. 

http://www.3dflow.net/technology/documents/3df-zephyr-tutorials/point-cloud-coloring-using-3df-zephyr/
http://www.3dflow.net/technology/documents/3df-zephyr-tutorials/point-cloud-coloring-using-3df-zephyr/
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  Point cloud selection section allows to identify the reference cloud to place the 
control points. 

 

 View Options section allows you to define how to see the cloud you are importing 
(with RGB color or reflectivity info). 

 

The buttons below allow to hide or show the two point clouds so as to simplify the 
identification of control points. 
 

Once the process is finished just click the Next button to move forward to the last 
window. Recompute Colors option is enabled by default and it can add color information 
to the laser scanner cloud. 
 

The ICP algorithm - Iterative Closest Point - improves alignment accuracy even if you 
should not use it when you are dealing with flat surfaces. 
 

In the Import to workspace section you can choose which cloud will be the reference for 
the alignment and which one will be moved so as to be aligned. 
 

Click now on Import point cloud button to complete the procedure. You will notice that 
the laser scanner cloud will be included into the list of dense clouds in the Project panel 
and below the point cloud generated with Zephyr. 
 

You can even merge the two point clouds and go on with the mesh generation. 
 

SRT transformation alignment 

 

Before starting you need to place at least three control points on the point cloud 
exploiting them for the clouds alignment. 
 

In this procedure you can use an external software that allows the processing of point 
clouds, such as CloudCompare, rather than the application that comes with the laser 
scanner equipment. 
 

After importing the laser scanner cloud in CloudCompare it is necessary to identify as 
many control points as those that have been placed in Zephyr. Each point must have the 
same position and the same name of the corresponding point in Zephyr. Once the 
identification of points is done simply save the list as a .txt file. 
 

The purpose of this first operation is to copy the reference system of the laser scanner 
cloud  identifying at least three points on it and importing it inside Zephyr so as to assign 
the same reference  system to the photogrammetric cloud as well. 
 

Getting back to Zephyr and looking at the Control Points tab on the right side of main 
interface you have to click on Scale model with Control points button and clicking then 
on Import constraints from file button in the new window in order to load the txt file 
where you previously save the point picked on laser scanner cloud. 
 

Now click on Ok to complet that step and close the window. 
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Simply click on Import > Import and align a cloud of points choosing the laser scanner 
cloud and selecting then the SRT transformation alignment procedure. 
Note that the imported cloud is immediately shown into Zephyr workspace. 
 

Now click on Next button to move forward. 
 

In the next window you can activate the decimation tool if the imported cloud contains a 
considerable amount of (million) points. This tool is disabled by default. Click on Next 
button to continue. 
 

Notice that the imported cloud is already aligned to the Zephyr cloud. Now click on Next 
button to continue. 
 

Recompute Colors option is enabled by default and it can add color information to the 
laser scanner cloud. 
 

The ICP algorithm - Iterative Closest Point - improves alignment accuracy even if you 
should not use it when you are dealing with flat surfaces. 
 

In the Import to workspace section you can choose which cloud will be the reference for 
the alignment and which one will be moved so as to be aligned. 
 

Click now on Import point cloud button to complete the procedure. You will notice that 
the laser scanner cloud will be included into the list of dense clouds in the Project panel 
and below the point cloud generated with Zephyr. 
 

You can even merge the two point clouds and go on with the mesh generation. 

Import a mesh 

These functions are available only in 3DF Zephyr Pro e 3DF Zephyr Aerial. 
 

It is possible to import an external mesh in Zephyr and the file formats available are the 
following: 
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 - obj 

 - ply 

 - dae 

 

Before using this tool you need to make a 3D reconstruction completing at least the mesh 
generation phase. In this way you can add the color information to the mesh you want to 
import. 
 

Tip: the mesh you are importing and the one generated with Zephyr must have the same 
reference system. In a nutshell you have to make the same procedure as in SRT 
trasformation alignment tool related to point cloud import. 
 

To start the tool just click on Import > Import mesh in the menu bar. Now click on 
Import mesh from file button. Timing to import depends on the size of the mesh file. 
 

Once the file is loaded you can click on Import  in the workspace button. 


